Booting OM 2008.08 from SD - Re: Openmoko Om 2008.8 Release

Olivier Berger oberger at
Sat Aug 9 08:11:11 CEST 2008

"Martin Šenkeřík" <martinsenkerik at> writes:

> Maybe can help reflashing your u-boot with some actual version...

Thanks for the suggestion.

Haven't tried that, but instead, I changed u-boot env to add a new
menu entry including init=/sbin/init.

It went a bit further this time : kernel boots and I can see the
booting splash screen (with boots and progress bar), although the X
server wasn't started, I guess : I get a black screen.

I updated the to
show an example menu with the init kernel arg.

Anyone succeeded in booting the new image from (micro)SD ?

>> I've just tried and install it like that on the SD's ext3 partition,
>> and copied the kernel to the first partition (VFAT).
>> But after booting, I'm stuck with a :
>> Kernel panic - not syncing: No int found. Try passing init= option to
>> kernel.
>> Too bad :( I'll have to flash ?

Olivier BERGER 
(OpenPGP: 1024D/B4C5F37F)

More information about the community mailing list