Network over USB flaky ? - Re: Booting OM 2008.08 from SD - Re: Openmoko Om 2008.8 Release

Olivier Berger oberger at
Sat Aug 9 23:59:00 CEST 2008

Olivier Berger <oberger at> writes:

> Andy Green <andy at> writes:
>> Somebody in the thread at some point said:
>> |
>> | But the first few boots I could not have USB networking working -at
>> | all-. Now it works, but I don't really know what was wrong.....
>> If you updated your U-Boot partway through your testing, for a while we
>> put out a U-Boot version that had 50% chance per boot to break USB
>> functionality for the whole session.  So I you updated it a few weeks
>> ago and then today, it can be that.
> Well, I'm afraid there could be something else.
> Now, I have found a way to boot to OM 2008.8 from SD (actually VFAT +
> EXT3).
> But I'm too unable to use network over USB now (works fine if
> rebooting to 2007.2 in flash).
> Still my u-boot is pretty recent :
> U-Boot 1.3.2+gitr18+64eb10cab8055084ae25ea4e73b66dd03cc1a0cb (Aug  4 2008 - 02:33:52)
> Any idea why USB may still be broken ? Maybe since it's running from
> SD instead of from flash ?

I kept trying, rebooted, tested, again, again, unplugged USB,
replugged... and TADA, at some point it magically worked ! 

I've typed-in a few commands, got networking (opkg update completed),
did a few more things... and ... it's now gone :(

# ping
PING ( 56(84) bytes of data.
>From icmp_seq=1 Destination Host Unreachable
>From icmp_seq=2 Destination Host Unreachable
>From icmp_seq=3 Destination Host Unreachable

no kernel message on desktop side : usb not unplugged...

I guess it's pretty flaky :( But still I see some (slow) progress ;)

I guess screen will be my friend.

Olivier BERGER 
(OpenPGP: 1024D/B4C5F37F)

More information about the community mailing list