2008.08 zecke gstreamer errors

Dylan Reilly dreilly at atariland.net
Sun Aug 24 20:05:38 CEST 2008

For what its worth, I figured out that the problem was related to how the
music data was stored. The music was being kept on an ext3-formated second
partition of the SD card. Despite having the correct references in fstab and
Qtopia's Storage.conf, the data was not being read correctly. I could,
however, play the music through gstreamer directly and using madplay. When I
changed to a single partition, fat-formatted data store everything magically
worked. I have not done any additional testing to see whether it was the
partitioning or formatting, but I could if anyone is interested.

On Sat, Aug 23, 2008 at 5:36 AM, Nishit Dave <stargazer.dave at gmail.com>wrote:

> On Sat, Aug 23, 2008 at 12:22 AM, Dylan Reilly <dreilly at atariland.net>wrote:
>> Using the 2008.08 testing repository from zecke, both the openmoko and
>> qtopia media players throw gstreamer errors on my device when trying to play
>> audio. Possibly related, the qtopia player can not read mp3 tag information
>> (all tracks are "unknown").
>> I have not had time to look into the cause for this yet. Has anyone else
>> experienced this and possibly fixed it? Could it be a package or
>> configuration related issue?
> You know what's weird?  Before applying the updates from Zecke's testing
> branch today, neither of the openmoko or qtopia mediaplayers were working
> for me.  OM was either throwing up gstreamer errors or did not seem to do
> anything, and the qtopia one didn't play anything and didn't even quit.
> After the updates and installing mplayer, both are working.  The QMP takes
> a while after starting and some cyclic pressing of > - || - > buttons for an
> mp3 file to play.  You could try to reinstall the gstreamer plugins.
> I still wonder what has happened to openmoko-mediaplayer2's volume button.
>   And why the FR doesn't have the most basic buttons: call pickup, call
> reject, and volume control.
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

Dylan Maxwell Reilly
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20080824/ddba435e/attachment.htm 

More information about the community mailing list