USB keyboards "silent" in terminal (FSO)

Carsten Haitzler (The Rasterman) raster at
Mon Aug 25 03:04:50 CEST 2008

On Mon, 25 Aug 2008 00:48:24 +0200 Fredrik Wendt <fredrik at> babbled:

> ons 2008-08-20 klockan 11:09 +1000 skrev Carsten Haitzler:
> > aaah excellent. my "hardware keyboard detection" works... reported with
> > bluetooth and usb... excellent! happiness is me. :)
> When is it supposed to kick in? I just can't get it to work ... Under
> FSO M2 I got /dev/input/event5 populated (after manually switching to
> USB host mode), and it works in console but ran into
> regarding X.

oh i just worried about detecting a "real physical keyboard" is there. didn't
worry about it actually delivering events in x... :)

> Using
> openmoko-openmoko-devel-image-glibc-ipk--20080824-om-gta02.rootfs.jffs2
> uImage-2.6.24+git36
> +a1e97c611253511ffc2d8c45e3e6d6894fa03fa3-r2-om-gta02.bin
> from buildhost/daily/freerunner/ I get zip out of the same keyboard that
> worked with FSO M2.
> I tried connecting the USB keyboard after my FreeRunner was connected to
> my laptop (first: FR connected to laptop, unplug, plug keyboard to FR)
> and also have the USB keyboard connected on boot (first: FR is off,
> connect keyboard, power on FR).
> Not having pand in that devel-image really made things more difficult to
> test. I guess I could try getting FR to use wifi and ssh from my
> computer to see what's going on, but using bluetooth is just easier to
> set up.
> / Fredrik

Carsten Haitzler (The Rasterman) <raster at>

More information about the community mailing list