[SOLVED]Backup rootfs and turn it into flasheable image

David Samblas dsamblasomcommunity at gmail.com
Tue Aug 26 14:46:46 CEST 2008

I have found what was wrong, mkfs.jffs2 select the best compress
algorith aviable, and that was lzo, that is not suported in kernel by
default, so excluding it from de select list adding "-x lzo"  param
solves the problem and make a pretty jffs2 to flash :), tested several
times :) 

on  Neo(or though an ssh session on Neo)

opkg mkfs-jffs2
mkdir  /var/tmp/root
mount -t jffs2 /dev/mtdblock6 /var/tmp/root

on PC
(pv used to se the progres of the operation, executed on ubuntu 8.04,
change neos ip if needed)
sudo aptitude install pv

ssh root at "mkfs.jffs2 -d /var/tmp/root -e 128 --pad
--no-cleanmarkers -x lzo" | pv -W >

scp root at


Nishit, why si so slow is a combination of usb 1.1 rate+ tcp reducing
even more this rate+ssh protocol even reducing it a little more+ strong
work compressing of neo CPU (when I have tested without compressing the
rate sensible increase but the jffs2 generated was about twice big)
But not I have not measured it but I beleave take less time than flash
El mar, 26-08-2008 a las 12:56 +0530, Nishit Dave escribió:
> On Mon, Aug 25, 2008 at 8:34 PM, David Samblas
> <dsamblasomcommunity at gmail.com> wrote:
>         I just flashed the resulting jffs2 file and no luck
>         a "precious" kernel panic arise
>         JFFS2 compresion type 0x07 not aviable
>         Error: jffs2_decompress returned -5
>         Any ideas??
> I had the same error code.  I had a working 2007.2 then.  Why does it
> so long to take a backup?
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list