Echo issue on OM2008.08 potentially solved

Al Johnson openmoko at
Fri Aug 29 19:38:10 CEST 2008

On Friday 29 August 2008, Florian Hackenberger wrote:
> Hi!
> Thanks to a posting from "Freerunner_User" on the hardware mailing list
> [1], I got hold of the hidden AT commands concerning the AEC and noise
> reduction support of the TI Calypso. I quickly tried these commands and
> it solves the echo problem for me. I injected
> AT%N0187
> using minicom and gsm0710muxd on Om2008.08 while qpe was running. On the
> next call the echo was gone. I have not modified my alsa .state files
> at all and I'm running the official OM testing ASU branch.
> Cheers,
> 	Florian
> [1]

I was installing FSO to try those commands too. I just tried AT%N0187 and it 
works. If you push the mic gain right up it will eventually start to break 
through, but this is _much_ better than before. It's really easy to run on 
FSO as gsm0710muxd and mickeyterm are already running. Just start a terminal, 
run mickeyterm and issue the AT command, then exit with Ctrl-D. All 
subsequent calls will be affected. You can even turn it off again mid call 
using AT%N0001 if you want to compare back to back. I haven't tried fine 
tuning  with any of the other values yet.

More information about the community mailing list