HAL update, OM2008.8

Nishit Dave stargazer.dave at gmail.com
Sat Aug 30 12:08:23 CEST 2008

On Sat, Aug 30, 2008 at 1:06 PM, Matt <matt.joyce at gmail.com> wrote:
> Nishit Dave wrote:
>> Hi,
>> The current upgrade of hal from 0.5.9-r6 to 0.5.11-r0 today through
>> the official repository led to the following exit message (relating to
>> haldaemon):
>> Cannot create link over existing -/etc/resolv.conf-.
>> which would be the case because of the earlier resolvconf problem
>> being solved manually by creating a real /etc/resolv.conf file.  Now,
>> should that file be replaced again with a link, and how?
> Move resolv.conf to /var/run/resolv.conf and then link /etc/resolv.conf
> to it.
> maybe.
Found an update on the wiki:

NOTE: Solusion: Steps to add missing scripts:

touch /etc/resolvconf/run/enable-updates
cd /etc ; rm resolv.conf ; ln -s /etc/resolvconf/run/resolv.conf .
mkdir /lib/resolvconf/ ; cd /lib/resolvconf/
wget http://kopparv34.mine.nu/list-records
Edit /etc/network/interfaces and remove the lines:
If we need to use the usb network more then just locally from the computer
in the other end of the USB-cable, login with ssh and add a default route
like this:
route add default gateway

I haven't tried it so far.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20080830/dcda92b4/attachment.htm 

More information about the community mailing list