[shr-u] GPS not working

Michele Brocco ssj2micvm at gmail.com
Wed Dec 23 15:10:47 CET 2009

On 12/22/09, Bill Kenworthy <billk at iinet.net.au> wrote:
> On Mon, 2009-12-21 at 21:52 +0100, Michele Brocco wrote:
>> On 12/21/09, Michele Brocco <ssj2micvm at gmail.com> wrote:
>> > thanks for the info guys. I will install zhone and report whether I
>> > can find out something or not. Right now with fso disabled I can get
>> > GPS NMEA data out of it. However no fix, position data or something
>> > else interesting except sometimes some unreadable Date and Time (ZDA)
>> > information which adjusted my time from year 1970 to 1999.
>> >
>> > On 12/21/09, Daniel Willmann <daniel at totalueberwachung.de> wrote:
>> >> Hello,
>> >>
>> >> On 12/21/2009 02:54 PM, Michele Brocco wrote:
>> >>> since i installed the latest SHR-U GPS seem to not work at all. The
>> >>> SHR GUI for reading satellites shows no entry at all even after 20
>> >>> minutes outside. I think that may be related to the following problem
>> >>> with the interface naming extracted from frameworkd.log:
>> >> [...]
>> >>> 2009.12.21 11:49:13.961 ogpsd                WARNING  (could not write
>> >>> to '/sys/bus/platform/devices/neo1973-pm-gps.0/pwron': [Errno 2] No
>> >>> such file or directory:
>> >>> '/sys/bus/platform/devices/neo1973-pm-gps.0/pwron')
>> >>>
>> >>> but the file is called power_on here. Am I the only one experiencing
>> >>> this (I know somebody having shr-u without that problem)? Is this
>> >>> really the reason why I dont get a single entry in the satellite list
>> >>> of the shr phoneui?
>> >>
>> >> This is "normal". Earlier kernel had pwron as node to control power to
>> >> GPS and since the change ogpsd just writes to both (and will always
>> >> complain about one not being there).
>> >> If you install zhone (which should be possible on SHR) you can open the
>> >> GPS tab and look at GPS in more detail. The chip will tell you which
>> >> SVs
>> >> it is currently looking for and if it is receiving data or not well
>> >> before they appear in the SHR GUI.
>> >>
>> I the meanwhile I tried with zhone and it seems to search for
>> approximately 13 different SVs without results for a loooong while
>> (around 20 minutes). Power On seems to work since zhone's GPS icon
>> activates after turning gps on through the shr settings gui. Also no
>> time sync or any other value is set.
> Use settings/position and "remove AGPS data" - I suspect that it
> installs with a AGPS data file that by default doesnt suit your location
> - I cant get a lock without cleaning it out after install, then its
> fine.
I tried to change GPS Antenna and to remove AGPS data but still no
luck so far. I will try to change with a third antenna in the next
days. Is there a way to see if there is some damage at the gps chip
itself? gpspipe and cat produce some nmea data in a 1Hz rate. thats
all i can see. but of course no fix data or meaningfull location data.

More information about the community mailing list