Freerunner, Qt Extended Improved, libswt issue

Juan Lucas Dominguez Rubio jldominguez at
Mon Dec 28 13:05:59 CET 2009

Hello, Sebastian.
yes, I tried -among other things- to install explicitly the jni package with no success.
In one of the tests, I got an "unsatisfied link error" even though the .so files needed were actually there. As if those .so files were useless.
In another test, one of the .so files was deleted (?) when trying to execute the SWT-based application (even though I removed all the writing permission. Amazing: there's a force stronger than linux permissions)
In the last tests, I got an error message that said something like "no more handles".
All this worked fine on OM 200X and on SHR
I thiought it would be too complicated to explain all those details, so I prefered to re-shape my question:
Anybody got the SWT Sample application shown here [1] to work on Freerunner + any of the Qt* distributions ('Qt Extended', 'Qt Extended Improved' or 'QtMoko')? (FYI: QtMoko seems to be a Debian distribution plus a Qt GUI)
[1] <> 
Juan Lucas


De: Sebastian Mancke [mailto:s.mancke at]
Enviado el: lun 28/12/2009 9:32
Para: jalimo-info at
CC: Juan Lucas Dominguez Rubio
Asunto: Re: [jalimo-info] Freerunner, Qt Extended Improved, libswt issue

Hi Juan Lucas,

Am Samstag, 26. Dezember 2009 02:24:40 schrieb Juan Lucas Dominguez Rubio:
> Hello, list
> I have installed 'Qt Extended Improved' in my Freerunner, then:
I do not know the 'Qt Extended ..' Distro. Are the GTK libraries available
there? (SWT needs them).

> opkg install libswt3.4-gtk-java jamvm gpsd classpath-gtk classpath-common
>  classpath

You should have the package libswt3.4-gtk-jni installed. It contains the
native libs for SWT and should normally come as dependency of libswt3.4-gtk-


> and I also added this repository in my conf files:
> -arm
> because one of the packages was asking for openjdk-6-jre and that's where I
>  found it.
> But now my app is not running, it says:
> Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-gtk-3448
>  or swt-gtk in swt.library.path, java.library.path or the jar file at
>  org.eclipse.swt.internal.Library.loadLibrary( at
>  org.eclipse.swt.internal.Library.loadLibrary( at
>  org.eclipse.swt.internal.C.<clinit>(
>    at org.eclipse.swt.internal.Converter.wcsToMbcs(
>    at org.eclipse.swt.internal.Converter.wcsToMbcs(
>    at org.eclipse.swt.widgets.Display.<clinit>(
>    at
> And indeed I dont have any folder /usr/lib/jni or any file *swt*.so in my
>  system.
> This worked fine in OM 2009 and previous.
> Any ideas?
> Regards,
> Juan Lucas

tarent Gesellschaft für Softwareentwicklung und IT-Beratung mbH
Geschäftsführer: Boris Esser, Elmar Geese
HRB AG Bonn 5168 - Ust-ID: DE122264941

fon +49 228 52675-17
mobil +49 171 7673249

Heilsbachstr. 24, 53123 Bonn,   fon +49 228 52675-0,   fax +49 228 52675-25
Weigandufer 45,   12059 Berlin, fon +49 30 5682943-30, fax +49 228 52675-25
Schützenstr. 18,  10117 Berlin, fon +49 30 27594853,   fax +49 30 78709617

-------------- next part --------------
An HTML attachment was scrubbed...
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ATT02796.txt

More information about the community mailing list