[FSO] Speed gps time to firxt fix up?

Fox Mulder Quakeman1 at gmx.net
Sun Jan 4 12:56:55 CET 2009

If the versions are compareable than it seems that your fso-frameworkd
is newer (> and fso-gpsd is older (0.7<0.8).
The only thing i know is that i had much problems with older fso-gpsd
versions and now it works without problems. Maybe this is a point where
you could investigate.

Debian uses the complete fso framework inclusive zhone as phone application.

I prefer debian because i have access to much more programs than with
any other distro. Even things like openoffice, wireshark, firefox etc is
available for the freerunner in debian. :)

The other side is that it doesn't fit into the 256MB nand flash. The
default install uses nearly 1GB but there seems to be people who tries
to fit a slimed version into nand. But for me this is no problem if i
have to install it on my sd-card (8GB). In return i have a full linux
with normal windowmanager and all possibilities i want and need.

The downside of this is that it is slower and consumes more memory than
most other distros. I think with a bit less ressource hungry
windowmanager it will improve quite a bit. But at the moment i use xfce
with all nice extras. ;)

Good thing is that i have one distro in nand and debian on my sd-card.
So i can boot what i want when i want.


lollisoft wrote:
> Sorry, my post should look like this :-)
> That's what I see when list installed:
> root at om-gta02:~# opkg list_installed | grep gps
> fso-gpsd - 0.7+gitr8f82d35ae83fdc00f2c4786257e98551b9dea995-r0.1 - 
> tangogps - 0.9.3-r3.1 - 
> root at om-gta02:~# opkg list_installed | grep framework
> frameworkd - - 
> frameworkd-config -
> - 
> root at om-gta02:~# opkg list_installed | grep fso      
> fso-gpsd - 0.7+gitr8f82d35ae83fdc00f2c4786257e98551b9dea995-r0.1 - 
> fso-sounds - 0.0.1+gitrb24d3c2e66fee10a5e288101cd1b6f5bbd3da7e2-r0.1 - 
> task-fso-compliance - 1.0-r1.1 - 
> root at om-gta02:~# uname -a
> Linux om-gta02 2.6.24 #1 PREEMPT Tue Nov 18 18:04:32 CET 2008 armv4tl
> unknown
> And - I am not using debian. My OS is FSO milestone 4.1 aka 'more homework'.
> Another question: Has debian also the possibility to run Zhone ? 
> Do you prefer debian before FSO ?
> Is debian as small to fit in internal flash (not on /media/card) ?
> This phone software is compact and therefore fast.
> Thanks
> Lothar
> Fox Mulder wrote:
>> I use debian with fso and when i install fso-gpsd no gpsd is installed
>> as dependency because it would make no sense.
>> Fso-gpsd IS the gpsd compatibility wrapper which does the same what gpsd
>> does for the client applications. So be sure not to have fso-gpsd and
>> gpsd installed. Both programs try to access the gps which doesn't work.
>> My current version of fso-gpsd in debian is 0.8-2 and my fso-frameworkd
>> is Both are from the official debian repository.
>> lollisoft wrote:
>>> I haven't success.
>>> My FSO is the 'more homework' version 4.1.
>>> Installing gpsd really installs fso-gpsd. Installing tangogps complains
>>> about having two
>>> versions matching gpsg, eg. the fso-gpsd and the compatibility (gpsd)
>>> wrapper that seems
>>> to be installed with fso-gpsd.
>>> What version do you use exactly (image locations) ?
>>> Tahnks
>>> Lothar
>>> lollisoft wrote:
>>>> Thanks,
>>>> I'll try that too. Also when the connections to the port are more than 0
>>>> it could be
>>>> useful to disabling illume to lower the brightness and the like.
>>>> Is this possible within a script ?
>>>> Lothar
>>>> Fox Mulder wrote:
>>>>> I did nothing special.
>>>>> I only deinstalled gpsd and installed fso-gpsd. Some time ago fso-gpsd
>>>>> wasn't working good at all. But a few weeks ago i tried again to
>>>>> replace
>>>>> gpsd with fso-gpsd and since than it works ok.
>>>>> Interesting is that with fso-gpsd the gps chip is activated as soon as
>>>>> a
>>>>> connection to the fso-gpsd port is opened. And it is deactivated when
>>>>> the last connection closes. This feature has pros and cons but at the
>>>>> moment i like it. :)
>>>>> Ciao,
>>>>>      Rainer
>>>>> lollisoft wrote:
>>>>>> Hi,
>>>>>> what did you made to get GPS working in general ?
>>>>>> See my post about GPS ...
>>>>>> Thanks
>>>>>> Lothar
>>>>>> Fox Mulder wrote:
>>>>>>> Since a few weeks i'm using fso-gpsd without any big problems so far.
>>>>>>> The only problem is that the TTFF (time to first fix) is always >1
>>>>>>> minute and sometimes it needs quite a lot of time. The only solution
>>>>>>> for
>>>>>>> me to be sure to get a fix within <30 sec is to use the agps tool
>>>>>>> which
>>>>>>> downloads the almanac and ephemeris from ublox for my region.
>>>>>>> The problem is, that the gps chip doesn't have any internal memory
>>>>>>> why
>>>>>>> it needs to download all relevant gps data every time it is powered
>>>>>>> up.
>>>>>>> So i thought if it is possible to save the relevant gps data before
>>>>>>> shutting down the gps which can be done by fso-gpsd or kernel
>>>>>>> automatically. Than after starting the gps fso-gpsd/kernel feeds back
>>>>>>> the data to speed up the TTFF. This would be the same way most gps
>>>>>>> receivers work.
>>>>>>> Maybe this is already implemented somewhere but i don't think so
>>>>>>> because
>>>>>>> the TTFF without agps is always quite slow.
>>>>>>> Ciao,
>>>>>>>      Rainer
>>>>>>> _______________________________________________
>>>>>>> Openmoko community mailing list
>>>>>>> community at lists.openmoko.org
>>>>>>> http://lists.openmoko.org/mailman/listinfo/community
>>>>> _______________________________________________
>>>>> Openmoko community mailing list
>>>>> community at lists.openmoko.org
>>>>> http://lists.openmoko.org/mailman/listinfo/community
>> _______________________________________________
>> Openmoko community mailing list
>> community at lists.openmoko.org
>> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list