Has anyone tried Qi?

Tarandeep Gill taran.iota at gmail.com
Thu Jan 8 08:45:14 CET 2009


I have a SMDK6410 board. I have successfully compiled  dfu-util, Qi,
and Openmoko kernel on my Ubuntu machine.

The SMDK6410 is just as I got it from the company, I haven't modified
its firmware. I have connected it to my computer with a  USB cable,
that goes into the OTG USB host port on the board (This is how the
Windows DNW utility transfers a Win CE image to the board).

So, when I use dfu-util to try to burn the Qi image into it, I get the
following error:

root at CONECTech-desktop# ./dfu-util -a u-boot -R
dfu-util - (C) 2007-2008 by OpenMoko Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

No DFU capable USB device found

Can you please tell me how to transfer the boot loader and the kernel
to the NAND?

I also have an Olimex OCD (that connects to the JTAG interface on the
board) , if it is needed anyway.



On Fri, Oct 31, 2008 at 12:45 AM, Andy Green <andy at openmoko.com> wrote:
> Hash: SHA1
> Somebody in the thread at some point said:
> | On Thu, 30 Oct 2008 11:35:40 +0100
> | Petr Vanek <vanous at penguin.cz> (PV) wrote:
> |
> |> On Thu, 30 Oct 2008 10:26:00 +0100
> |> "arne anka" <openmoko at ginguppin.de> (AA)
> |> wrote:
> |>
> |>>> I have tried it and i liked it. It was definitively faster. I might
> |>>> stick with it for a while i hope.
> |>> how does it play with the dead battery issue?
> |>
> |> well, this i cannot answer as i have three batteries and just swap them
> |> around... i can try to run one completely empty and see what happens.
> |>
> |
> | seems like no luck with empty battery, but i hadn't have much time to
> | test. and, for some reason, i cannot Qi boot my SD located distro.
> | Results on NAND based distro give me today the same or almost longer
> | booting times. The original Qi from Andy was definitely faster.
> |
> | Someone mentioned sound issue... right, seems to be that way too - no
> | sound, but i haven't tested it thoroughly now.
> |
> | I had been using older qi from Andy and i am not sure, but think that
> | it didn't suffer these issues... well, let's wait, it's still fresh.
> The sound thing is a kernel issue I believe.  Up in stable-tracking
> branch of kernel the upstream init of the codec chip is done differently
> now and I think this is resolved.  But stable-tracking has some issues
> being worked on that stop it replacing stable right now.
> The empty battery thing on GTA02 A5 anyway is a hardware issue that is
> happening before the CPU is booted, so Qi can't directly affect it.  It
> can indirectly affect it though, when it does run it enables charging
> immediately.
> - -Andy
> Version: GnuPG v1.4.9 (GNU/Linux)
> Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org
> agQAnRcAelL2uAg4qRQU7EC7kqrzGlak
> =uTZ7
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list