[debian] 2.6.28 kernel problems (was: Re: When will kernel 2.6.24 be replaced...)

Fox Mulder Quakeman1 at gmx.net
Thu Jan 8 13:15:55 CET 2009

Paul Fertser wrote:
> rm -rf staging
> mkdir -p staging
> make ARCH=arm modules_install INSTALL_MOD_PATH=staging
> cd staging
> tar czf ../modules-whatever.tar.gz .
> cd ..
> And then scp your modules-whatever.tar.gz to FR and untar to /.

Sorry if i'm annoying you, but now it worked. :)

After i read "build" how you mentioned i found the problem why no
modules tar.gz were created. The build script needs a second parameter
to create the archive where the parameter can be whatever. I don't know
why this check is build into the script but with help of that it worked.
Second problem was that i had to copy the .config into the dummy
directory and not the linux-2.6 dir to be found.
The problem is that the info on the toolchain wiki [1] is a bit wrong
concerning kernel compiling. So i added a remark with the right steps on
this page.

I updated my fso-frameworkd with help of the patch from [2] and copied
the kernel and modules to the right place. Than i booted with the new
2.6.28 kernel but it didn't work at the first try.

I have a 64MB swap file activated in /etc/fstab which lies on the third
vfat partition of my sd-card. And at the point where the message
"activating swap partitions" came it hung and showed an error message
after 120sec timeout. So i thought that vfat wasn't working at boot time
and i disabled the swap file.
Next boot goes through and the freerunner started without any suspicious
error messages. After it booted the sd-card was mounted what means that
vfat should work. I had the same problem with the swap file a few weeks
ago with an older andy kernel and i don't know what the problem is.

But after a short test i found a few things that doesn't work anymore.
Don't know if they are related to the fso-frameworkd patches or to the
new kernel.
Openmoko-panel-plugin doesn't start anymore with an error message [3].
The system time was set back to 1 Jan 2000. And the greatest problem i
had was wlan. I could access the eth0 device and it shows all available
wlan stations but i can't use my wpa2 protected wlan with wpa_supplicant
anymore. Iwconfig showed that i should be connected to my wlan but i
can't get an ip with dhcp anymore like with my old 2.6.24 kernel. The
dhcp client always tries and after 6-7 dhcpdiscover it exits with "no
dhcp server available".

That is the reason why i'm now back to the 2.6.24 kernel where these
things work. Maybe the userspace tools need a bit more tweaking before
they work together with the new 2.6.28 kernel. Or the configuration for
the 2.6.28 kernel have to be modified to work with my system. I removed
a few unneeded modules (i.e. Android things) and added a few modules but
i don't think that these have to do anything with my problems. :/

I attached my dmesg log. Maybe someone know of any other modifications i
can try to get the new kernel running a bit smoother. :)




Traceback (most recent call last):
  File "/usr/bin/openmoko-panel-plugin", line 52, in <module>
    icon = PanelPlugin(dbus_object, notificationAvailable)
  File "/usr/lib/python2.5/site-packages/panelplugin/PanelPlugin.py",
line 32, in __init__
  File "/usr/lib/python2.5/site-packages/panelplugin/PanelPlugin.py",
line 46, in configReader
  File "/usr/lib/python2.5/site-packages/panelplugin/PanelPlugin.py",
line 72, in appendIcon
    self.icons.append(USBIcon(self.dbus, self, self.notificationAvailable))
  File "/usr/lib/python2.5/site-packages/panelplugin/USBIcon.py", line
17, in __init__
    PowerStateIcon.__init__(self, self.dbus, None, None, "UsbHost",
self.parentObject, "usb", self.notificationAvailable)
  File "/usr/lib/python2.5/site-packages/panelplugin/PowerStateIcon.py",
line 19, in __init__
    self.powerstate = self.dbusdeviceiface.GetPower()
  File "/var/lib/python-support/python2.5/dbus/proxies.py", line 68, in
    return self._proxy_method(*args, **keywords)
  File "/var/lib/python-support/python2.5/dbus/proxies.py", line 140, in
  File "/var/lib/python-support/python2.5/dbus/connection.py", line 622,
in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod:
Method "GetPower" with signature "" on interface
"org.freesmartphone.Device.PowerControl" doesn't exist
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dmesg
Url: http://lists.openmoko.org/pipermail/community/attachments/20090108/0165cecd/attachment.txt 

More information about the community mailing list