[debian] 2.6.28 kernel problems

Paul Fertser fercerpav at gmail.com
Thu Jan 8 13:48:15 CET 2009


Fox Mulder <Quakeman1 at gmx.net> writes:
> Sorry if i'm annoying you, but now it worked. :)

No problem, i'm glad it worked :)

> After i read "build" how you mentioned i found the problem why no
> modules tar.gz were created. The build script needs a second
> parameter

I think it needs a first parameter exactly as described on the wiki.

> Second problem was that i had to copy the .config into the dummy
> directory and not the linux-2.6 dir to be found.

I have no idea where that "dummy" directory came from :) I'm afraid
you're misinterpreting the build script. It seems to me that
instructions on wiki are correct.

> error messages. After it booted the sd-card was mounted what means that
> vfat should work. I had the same problem with the swap file a few weeks
> ago with an older andy kernel and i don't know what the problem is.

There was a test report from a user stating that his uSD is unstable
unless he lowers sd_clock. It might be a problem here, as well.

> Openmoko-panel-plugin doesn't start anymore with an error message
> [3].

That's because you use an old unfixed version of o-p-p that tries to
read information about usb host power from /sys nodes that were
changed. I think you can fix it yourself with the help of
and suggest to o-p-p developers to be compatible with andy-tracking.

> And the greatest problem i
> had was wlan. I could access the eth0 device and it shows all available
> wlan stations but i can't use my wpa2 protected wlan with wpa_supplicant
> anymore. Iwconfig showed that i should be connected to my wlan but i
> can't get an ip with dhcp anymore like with my old 2.6.24 kernel. The
> dhcp client always tries and after 6-7 dhcpdiscover it exits with "no
> dhcp server available".

That clearly looks as a regression. I think you should write in
details what problems with wlan you experience along with
wpa_supplicant debug output and relevant dmesg to the kernel mailing
list, where it would (hopefully) be investigated. For me wlan with wpa
(not wpa2) works just fine.

Be free, use free (http://www.gnu.org/philosophy/free-sw.html) software!
mailto:fercerpav at gmail.com

More information about the community mailing list