[2008.12] Anyone get iptables working?

Nick Van Fossen stix213 at hotmail.com
Thu Jan 8 20:09:30 CET 2009

So, with 2008.9 I was using iptables to tether my ubuntu laptop to my freerunner's gprs connection.  
But as of 2008.12 I'm getting an "Illegal instruction" error each time I run the iptables command.  

Commands I run on the freerunner to enable tethering after gprs connection:
iptables -v -A POSTROUTING -t nat -j MASQUERADE -s
sysctl -w net.ipv4.ip_forward=1

I've noticed that most but not all iptables commands generate the same "Illegal instruction" error as well.  
Has anyone got around this yet?

I've installed iptables, iptables-utils, and upgraded libgcc1 to v4.2.4-r5.1 from the angstrom repository.  


Windows Live™ Hotmail®: Chat. Store. Share. Do more with mail. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20090108/fc21f3bf/attachment.htm 

More information about the community mailing list