[om2008-9] Never able to successfully backup the jffs2 partition...

Al Johnson openmoko at mazikeen.demon.co.uk
Wed Jan 14 17:28:24 CET 2009

On Wednesday 14 January 2009, john dowd wrote:
> Well I tried the NeoTool but it has its limitations. I was going to
> copy my current configuration to the uSD card as the backup. I tried
> the wiki page "Booting From SD" and was going to prepare the uSD card
> by partitioning it. I then saw that there is an entry:
> /dev/mmcblk0p1          497920        48    497872   0% /media/card
> when I do a "df". When I go to the mount point I found this file:
> qtopia_db.sqlite
> What the heck is this file doing there?

qtopia has an option to index media files on the SD, and this is enabled by 
default on the 2008.x images for the first partition. IIRC this ends up in 
the file you describe.

> From what I understand, I must partition the uSD and then copy kernel
> & rootfs to the various partitions. Why would an app. have grabbed the
> uSD card?

See reason above. You can blow the file away without problems. It may get 
recreated on your first partition if you use 2008.x again, but that shouldn't 
cause any problems. If you really don't want it you can disable the indexing, 
but I can't remember the file this option is defined in.

More information about the community mailing list