[2008.12] Qwerty keyboard and wrench

"Bernd (Jesus McCloud) Prünster" bernd.pruenster at gmail.com
Fri Jan 16 17:41:54 CET 2009

naguz schrieb:
> Hi,
> Tried your patch now. It gives me the qwerty-"button" back, but it only
> toggles the qte-keyboard. Not the illume one. The wrench is till not there,
> so i have no way of changing it either.
> It should have been possible to define which keyboard to use via ssh. Life
> would bo so much easier then..
> Not related to ypur patch:
> I cannot get rastermans keyboard to work in hte illume-theme either. Only
> the default illume one. Yet I have tried every guide in every wiki (well,
> almost, anyway) to get rastermans keyboard working. I do not understand
> this.
> Running OM2008.12, installed all availible updates
> buergi wrote:
>>> After using the neo for a while, again the qwerty keyboard disappears and
>>> I
>>> have to reboot to have it back.
>> i've the same problem, but only sometimes, not very often.
>> i've made a dirty patch package[1,2,3] for illume-theme-asu
>> (0.0+svnr4783-r7.04) a few days ago, it works great.
>> most of the time there is even no need to set
>> QTOPIA_NO_VIRTUAL_KEYBOARD=1 anymore, but as you said i discovered that
>> sometimes qtopia takes over and suddenly illume's keyboard is gone and
>> the qtopia eyboard reapperars. after a
>> rm -fr ~/.e ; /etc/init.d/xserver-nodm restart
>> the illume keyboard is back again.
>> the reason is that illume sets kbd.use_internal=0 in illume.module.cfg,
>> no idea why.
>> this patch also brings back the wrench, but the problem is that the
>> content of the subdialogs are shifted right, out of the visible area,
>> see the screenshot[4].
>> i've no idea why that happens, or how to fix it, does anyone have an idea?
>> buergi
>> [1]
>> http://pbuergi.pb.funpic.de/openmoko/pkgs/activate-illume-keyboard_0.1_armv4t.opk
>> [2]
>> http://pbuergi.pb.funpic.de/openmoko/pkgs/activate-illume-keyboard.tar.gz
>> [3] http://pbuergi.pb.funpic.de/openmoko/howtos/howto_illume_kbd.txt
>> [4] http://pbuergi.pb.funpic.de/openmoko/illume-cfg-dialog.jpg

Sorry to warm it up again, but i was even looking into the fdom tarball 
and trying out the themes, but i didn't find anything useful.
the qwerty button is no problem, but the wrench is (as already said, the 
config dialogs are missing/outside of the screen).
did anyone suceed in building a theme that features a working wrench?
i don't know why i am suddenly so keen on this.

More information about the community mailing list