QTMoko - Diffuculty trying to mount sd as USB

swoody swoody at ubuntu.com
Thu Apr 15 20:13:14 CEST 2010

(sorry for the double-post Jose)

Yes, that is what I figured out rather quickly :) I ran the commands again
from QTMoko (v21) on my FreeRunner, and I still got a ton of errors. I
then reverted back to v19, and still had the same issues. Then I tried
installing SHR-t, and things worked perfectly, all of the commands worked
without error, and I was able to see my phone's sd card as a USB device on
my computer. I then installed QTMoko on the sd, and left SHR-t on the
nand, so now I'm dual-booting the two of them. Thanks for your post
though! I do think it may be helpful for us FR-noobs if someone could just
put a note on that wiki page that it should be run on the phone OS, and
not on the host computer.

- Woody

> A Dijous, 15 de d'abril de 2010 01:49:57, swoody va escriure:
>> Well, I've been trying my darnedest to get the sd card in my phone to
>> mount as a USB drive. I have been Googling and trying to use this guide
>> from the wiki to no avail:
>> http://wiki.openmoko.org/wiki/Using_the_Neo_as_an_USB_Mass_storage_device
> All of those scripts are intended to run on the fr
>> .....
>> [ 1959.576070] usb 4-2: new full speed USB device using uhci_hcd and
>> address 3
>> [ 1959.791253] usb 4-2: configuration #1 chosen from 2 choices
>> [ 1959.800462] eth2: register 'cdc_ether' at usb-0000:00:1d.2-2, CDC
>> Ethernet Device, 00:1f:11:01:13:f6
> This is output from your host when it recognizes the FR
>> The next step, I then run 'rmmod g_ether', that module isn't existent.
>> So
>> through dmesg I find the driver which is active, and I tried disabling
>> that: "rmmod cdc_ether" This is the only command which didn't give me an
>> error message.
> This is normal newest qtmoko have g_ether built-in ( not as a module) and
> a
> kernel that provides it as a module is needed but from the /errorless/
> 'rmmod
> cdc_ether' I suspect that those commands are run on the PC and they should
> be
> run on FR.
>> On the last command (modprobe g_file_storage file=/dev/mmcblk0 stall=0),
>> I
>> get the output:
>> FATAL: Error inserting g_file_storage
>> (/lib/modules/2.6.32-21-generic/kernel/drivers/usb/gadget/g_file_storage.ko
>> ): Unknown symbol in module, or unknown parameter (see dmesg)
>> After checking dmesg again, I now see:
>> [ 1830.381547] g_file_storage gadget-lun0: unable to open backing file:
>> /dev/mmcblk0
>  this is also on the pc, isn't it?
>> I'm nearly at my wits end here. I don't have access to a card reader,
>> and
>> I tried setting up 3 different phones (non-FR's) as USB drives, but each
>> one has it's own unique issue. So I'm left hoping someone out there may
>> be
>> able to help me out with this. I would really appreciate any ideas you
>> all
>> may have. Thanks in advance!
> For use the neo as an usb-storge you do need a kernel (on the neo ) that
> supports USB gadget drivers as modules 'g_*.ko' ( shr-u provides them on
> kernels 2.6.29). I have just followed the steeps on the wikipage and works
> ok
> (I had to disconect and conect the usb cable for the pc to recognice
> periferic
> change)

More information about the community mailing list