[SHR-U] Wifi stopped working

Michele Brocco ssj2micvm at gmail.com
Mon Apr 26 11:30:55 CEST 2010

to be honest. Mokonnect rarely worked for me. I would also suggest u
to use wpa_supplicant or similar wifi tools.
Usually I turn on wifi using the shr settings ui and then run
wpa_supplicant and udhcpc. That works 99% of the time if the interface
is up.

Good luck

On Mon, Apr 26, 2010 at 11:17 AM, HansV <hans at vanpee.be> wrote:
> [quote]Wifi seems unavailable, but after seeking the ML I found there is a
> bug
> in FSO MS5 (MS5 is the revision ?) and I had to do :
>      echo s3c2440-sdi >/sys/bus/platform/drivers/s3c2440-sdi/unbind
>      echo s3c2440-sdi >/sys/bus/platform/drivers/s3c2440-sdi/bind
> in order to get eth0 back. [/quote]
> I entered the commands above and eth0 is available now. But Mokonnect still
> doesn't work, even after rebooting the FR. It says:
> Wifi device seems to be off, trying to power it on...
> This message takes forever. When the FR goes in standby the Wifi symbols is
> shown in the top-shelf.
> In Settings->Connectivity I can't change the WiFi setting, it always stays
> in 'Automatic'.
> After the reboot I had to enter the above commands again to get eth0 back.
> The error message is now followed by:
> Failed powering on the device or it was still not found in connman.
> --
> View this message in context: http://openmoko-public-mailinglists.1958.n2.nabble.com/SHR-U-Wifi-stopped-working-tp4562468p4961739.html
> Sent from the Openmoko Community mailing list archive at Nabble.com.
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list