Is xserver-xorg-video-glamo freezy for anyone else than just me?

Josh Thompson om-comm at
Fri Apr 30 15:16:06 CEST 2010

I'll add something to this that I was recently reminded of.  The freezes occur 
much more frequently with GTK based apps.  I have a utility sort of app I 
wrote that I leave running all the time.  After one of the upgrades (several 
months ago), I noticed that elementary based apps were significantly faster 
than GTK ones; so, I rewrote my app in elementary.  After that, the freezes 
didn't happen nearly as often.

Last weekend, I was using a GTK based app a fair amount and experienced 
several freezes.


On Friday April 16, 2010, Josh Thompson wrote:
> I occasionally encounter this and was also thinking I must have some edge
>  case hardware glitch since I haven't heard anyone else talk about it.  In
>  my case, I wouldn't say it's completely random - there's always something
>  I do that is graphics related that causes the freeze.  It's never
>  something repeatable, but it is always something related to the contents
>  of the screen being updated.  I think that's what you are describing as
>  well.
> I've not reported it before because it is so random and difficult to debug.
>   I do software development professionally and know how hard it is to help
>  someone with a problem that can't be intentionally reproduced.
> I'm using SHR-T.  The image is dated March 3rd, 2010.  I downloaded it and
>  the "latest" kernel image at the same time on March 10th.  It is kernel
>  version 2.6.29-rc3.  This is the most stable image I have run yet.  I
>  tried doing some upgrades at one point, but had more issues; so I
>  reflashed the image.  With this image, I'm probably down to only having
>  this type of freeze maybe once every 2 weeks or so.
> I've never tried fbdev.
> If anyone of the devs have some suggestions as to how to try to debug this,
> I'd be happy to try.  Maybe a script that periodically gathers and saves
>  some data that can be reviewed after rebooting?
> Josh Thompson
> On Wednesday April 14, 2010, Neil Jerram wrote:
> > I've raised this rather vaguely a couple of times before, and IIRC no
> > one else said that they see similar problems.  This time I'll try to
> > be clear and so hopefully attract a more definitive response.
> >
> > Simply, whenever I try switching to glamo for a while (instead of
> > fbdev), I find that my phone freezes after a while: the screen and
> > buttons are unresponsive, and I can't ssh in.  My only recourse is to
> > pull out the battery - which is of course a concern, as I could then
> > be corrupting the filesystem.
> >
> > It seems completely random, and not associated with any particular
> > action.  Today, for example, it happened very quickly after booting
> > up:
> > - boot up and wait for UI to appear
> > - click on keyboard icon to bring up the matchbox keyboard
> > - click on Ctrl, Alt, and X - which should bring up an xterm
> > - freeze.
> > On other occasions, that same sequence works find.  Some times the
> > freeze happens after a day or more of use.
> >
> > I see this in Debian, which is my main distro.  I also see it whenever
> > I decide to try SHR again - and it effectively prevents me from being
> > able to try SHR for very long.  (In Debian, I can just switch back to
> > fbdev.)
> >
> > Does anyone else see this?
> > If not, I'm guessing it could be caused by a specific hardware fault
> > on my phone - any ideas on how I might investigate that further?
> > Once in the frozen state, is there anything better/safer to do than
> > pulling out the battery?
> >
> > Many thanks!
> >
> >      Neil
> >
> > _______________________________________________
> > Openmoko community mailing list
> > community at
> >
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list