[QtMoko] No GSM network after buying new battery

Alishams Hassam alishams at interchange.ubc.ca
Thu Feb 4 15:26:03 CET 2010

On Thu, 2010-02-04 at 00:25 +0200, Margo wrote:
> Hi,
> I bought a new GTA02 battery from the Pulster shop. If I replaced my
> old battery with the new one, my freerunner couldn't connect to the
> GSM network. The message "No network" stays on the homescreen and the
> touchscreen doesn't respond (The power button does).
> If I ssh to the phone and restart qpe, the spinning clock icon stays
> on the homescreen and the screen keeps flickering. The touchscreen now
> responds but still no GSM network and it doesn't show my SIM contacts.
> Everything works if I use the old battery.
> I checked with SHR testing too - no problem there with the new
> battery. So it seems to be QtMoko problem.
> It's a very strange problem and I don't know what to do or what log
> files to check. Has anyone else seen such thing? Or can someone who
> bought a battery from Pulster try if QtMoko works with it?
> Margo
Okay, using v16d, on first boot it was fine but on second boot and there
after I had the same issue with "No Network" and unresponsive screen.
Though in the power menue I was able to restart QTE and had the frozen
clock. I wanted to check this out with my old battery that came with the
FR but it didn't have enough charge left, so I put back in the other
battery and almost everything worked again except accessing the hardware
clock (though i didn't check to see if that worked before)... weird! I
need a working phone for tomorrow so I'm not touching shit, but I'll see
if I can reproduce this in the comming days (hopefully with relevant
logs). As for the logfile, enabled some stuff in the QTE logging app (in
categories) and then check /var/messages .

More information about the community mailing list