[Shr-User] Quick e-mail poll: Still using your Freerunner?

Helge Hafting helge.hafting at hist.no
Sat Feb 6 21:54:19 CET 2010

>	>Does anyone else have trouble doing opkg ugrade over gprs? mine hangs
>	>after a bit.
>	I never tried that - but make sure the thing doesn't suspend.
> The problem happens somewhere between the wget application and the kernel stack.
> It shows up with larger files being downloaded. Not too large, a few dozen kB is enough.
> When I see it happening,  I repeat the wget download that opkg was trying to do, and I can see that wget is 
> actually in "stalled" state after the first kB. If I retry the download with the "continue" option, it 
> eventually downloads the whole file, retry after retry, chunk by chunk.
> This only happens with GPRS, so I assume it is related to kernel or pppd or around this...

Have you tried a different kernel? The kernel is in a separate flash, so upgrading the root filesystem
doesn't change the kernel, it must be installed separately. It could help - if it is a kernel problem.

If nothing helps, consider trying a different phone company. The problem could be there too.

Helge Hafting

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20100206/0932fd61/attachment.htm 
-------------- next part --------------
Shr-User mailing list
Shr-User at lists.shr-project.org

More information about the community mailing list