[SHR-U] Wifi stopped working

vancel35 vancel at thespazcat.com
Fri Feb 12 18:43:49 CET 2010

On a recent update/upgrade, I lost my ability to see wifi connections.  I'm
not sure what caused it, and I've done several things to see if I can bring
it back, but I've had no luck so far.  I'm sure it's something simple, but
since I really didn't use wifi before December, I'm still somewhat new to
the FR Wifi game.

Here are the wifi packages I have installed

$ opkg list-installed | grep -i wifi 
connman-plugin-wifi - 0.46-r5.4
task-base-wifi - 1.0-r87.4

Here are the wpa packages I have installed.

$ opkg list-installed | grep -i wpa 
wpa-supplicant - 0.6.9-r5.1.4
wpa-supplicant-passphrase - 0.6.9-r5.1.4

When I run Mokonnect I get the following symptoms (at least I think they may
be symptoms).
- Mokonnect uses significant (between 5 and 20% CPU) when on the Wifi
configuration page (the one with the "Scan" button).
- When I click the "Scan" button, nothing happens.  It used to show me the
visible SSID's as expected.
- When I click on the "Apply" button I get the following message:
   - Wifi device seems to be off, trying to power it on...
   - Failed powering on the device or it was still not found in connman.

I can turn on the Wifi device manually in SHR-Settings -> Connections, but I
never get the Wifi icon in the shelf.  (I used to get the icon every time) 
When I try again after I've manually turned on the Wifi antenna, I get the
same message, so I would guess that it's the 2nd part saying that the wifi
device is not found in connman.

I've upgraded every day since I first lost wifi hoping that maybe something
was broken, but the lack of posts on the list regarding wifi makes me think
something went wrong on my specific upgrade.  With this in mind, I removed
and reinstalled all of the packages that I could find regarding wifi or wpa,
and some other packages accidentally because of opkg recommending the option
to force removal of dependent packages.  I reinstalled all of them, and
still no luck.

Any help would be appreciated.  I'd rather not have to reflash if possible,
but I guess I will if necessary.

View this message in context: http://n2.nabble.com/SHR-U-Wifi-stopped-working-tp4562468p4562468.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

More information about the community mailing list