problems getting android to run

Serdar Dere serdar at
Sat Feb 20 01:23:38 CET 2010

Hi Jozef,

how did you tried it?
here is a short review:
unpack contents of tar.gz to fat
run nor
boot from micro sd
that should work
flashing kernel.img to kernel and system.img to rootfs should also work 
(if you are able to use usb cable to flash)

master/eclair is experimental if you want to try you can do it.

Useing only sd for booting should work too, there must be an issue at 
We are trying to think a new solution of the installer so we can use 
every qi we want and not reflash it everytime

Greetings Serdar
Am 19.02.10 23:28, schrieb Jozef Siska:
> Hi,
>    I was trying to get adnroid running on my freerunner...
> I first tried the "automated install" (i put it o a fat-only sd, and then
> also on one with exactly one fat and one ext2 partition...)
> It booted, installed qi then showed a white screen and rebooted, the red
> led blinked (might be that it blinked multiple times very fast, hard to
> say..), vibrated and then stayed on the white screen
> The "blink" of the red led was shorter then a "normal" boot (I put
> in a sd card with shr on it and it booted ok, the red led blinked
> shortly (presumably for the first FAT partition) and then lighted-up for
> a longer time before the kernel came up...)
> I tried flashing the kernel and rootfs manualy through dfu-util
> (kernel.img and system.img, though I am not really sure if these are the
> right files...), but it seems that qi can't boot it.
> When trying without a sd card the red led lights up (for a longer time,
> like when I was able to  boot shr from sd), it vibrates shortly 2 times
> and nothing else happens...
> With a sd card without a usable system, it just blinks and vibrates.
> The same happens, when I flash a shr kernel and rootfs to the neo, so it
> seems to be a qi problem... (NOR u-boot boots the shr kernel just
> fine..., gets a CRC error on the android kernel, which is what I expected...)
> Then I tried loading the kernel through dfu-util directly to memory and
> booting it, this booted the kernel, displayed a logo and stayed
> there...
> Is there any way to disable the logo / enable some debug output to see
> what is going on?
> I tried  android-on-freerunner-cupcake-0.2.0-RC1.tar.gz
> and also
> android-on-freerunner-cupcake-daily-20100214.tar.bz2
>   and
> android-on-freerunner-master-daily-20100210.tar.bz2
> from
> the "master" branch doesn't have the logo, so it shows a lot of output,
> I saw a lot of "nand_read_bbt: bad block..." mesasges, though if I boot
> up shr, I can mount and use the mtd partition without problems...
> (or if I flash and run SHR from nand...)
> the last screenfull of messages  looked like:
> init: cannot find '/system/bin/ifconfig', disabling 'usb-ether'
> init: command 'class_start' r=0
> init: processing action 0x37c20 (boot)
> init: command 'mount' r=0
> a lot of
> init: command 'chown' r=0
> and 'setprop' r=0
> ...
> init: processing action 0x34e40 (property: persist.service.adb.enable=1)
> init: starting adbd
> init: command 'start' r =0
> s3c-ohci s3c-ohci: susped root hub
> and that it stayed there...
> Btw, for any "it stayed there" I usually went doing another things and
> left it few times for even an hour... So I guess it certainly wasn't
> doing anything... ;)
> Any hints / suggestions?
> yoyo
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list