[SHR-U] shr-launcher cannot set categories

Andrew Stephen andrew.stephen at gmail.com
Tue Feb 23 02:41:56 CET 2010

I've regularly tried launcher since soon after the first release, and
have never been successful adding applications to the categories.  I
have just tried this again, on a freshly upgraded SHR-U.

I installed via "opkg install shr-launcher"

When I go to "Category -> Set App Categories" I get an empty list:


If I click on the "Category" button and choose a category from the
drop list, I get an immediate segmentation fault with no other error

If I go to "Configure" and tap the "App Icons" -> "Category" and
choose a category button I also get a segmentation fault with no other

In both cases I get the following on stdout:

  restoring state
  db ver:37
  showing window
  Getting SMS data..
  Getting Calls data..
  dbus init over. opim data pending......
  Updating SMS data..
  Updating Calls Data..

and this on stderr:

  Segmentation fault

Is there anything else I should try?
Andrew Stephen

It is absurd to divide people into good and bad. People are either
charming or tedious.
  - Oscar Wilde

More information about the community mailing list