qi-bootmenu-0.1 problem with menu

Marc Andre Tanner openmoko at brain-dump.org
Fri Jun 11 11:42:24 CEST 2010

On Tue, Jun 08, 2010 at 02:12:11PM +0200, Fox Mulder wrote:
> Hi,
> i use latest qi-bootmenu v0.1 for my GTA02 but i have a strange problem.
> When i powerup my Freerunner and than press AUX to start the bootmenu it
> always shows the big openmoko logo and starts the bootmenu. But it
> doesn't always show the possible bootable partitions. I tried it 15
> times and in 7 cases it shows all three bootable partitions on my
> sd-card. In the other 8 cases it only shows poweroff in the bootmenu.
> And the cases when it worked and when not seemed randomly distributed.
> Is this a bug or do i have to do something else to get it working all
> the time?

It could be that the sd card is not yet ready when the bootmenu
is started.

The following commit which isn't included in the pre build binaries
should help for the second stage part.


You could try tweaking the first stage kernel parameters (rootdelay=...).

Once I find some time I will update everything to 2.6.34 and give it
some more testing. However I am currently quite busy.


 Marc Andre Tanner >< http://www.brain-dump.org/ >< GPG key: CF7D56C0

More information about the community mailing list