Serious problems after failed upgrade

vancel35 vancel at
Thu Mar 18 08:32:04 CET 2010

Brian-32 wrote:
> This is probably a stupid question but have you tried removing the
> battery and leaving the FR unplugged for ~15 minutes and then see if
> you can get the NOR boot menu? I only ask because I've had a similar
> issue and this solved my problem.
> As far as the desktops not seeing the device via USB do you get any
> useful info from doing an lsusb or lsusb -vv as superuser ? What does
> ifconfig say ? I recommend trying this on both the FR and your
> desktop. Perhaps the device name is different from what it normally is.
> I use the following on my desktop to get networking up:
> ip addr add dev eth4;iptables -A POSTROUTING -t nat -j
> MASQUERADE -s;sysctl -w net.ipv4.ip_forward=1
> Your device may vary in the above example the FR is eth4. 
>> > > The interesting thing about the USB port is that if I plug the
>> > > adapter into the FR while it's turned off, it recognizes the
>> > > connection and boots (as expected) but somewhere along the way the
>> > > USB port is completely disabled. I don't know if it's a mokonnect
>> > > failure or what, but something is completely hosed.  So much that
>> > > I used to be able to take the battery out as long as it was
>> > > connected to the charger, but now it turns off as if it wasn't.
>> > > 
> It sounds like the USB port is okay but since Qi doesn't initialize
> USB you have to rely on the kernel to do it and it sounds like your
> install isn't.
>> > > Would I be able to fix it if I had a debug board?
>> > > 
> I don't see how NOR could be broken since this is an FR we're talking
> about.
>> > > I also need the buzz fix done on my phone, so if there were a US
>> > > company that I could send the phone to that would do that work,
>> > > maybe they could reinstall the bootloader so that I could at least
>> > > get to the boot menu. That's really all I need is to get to the
>> > > boot menu and I can do the rest from there.
>> > > 
> I hope you get the issue resolved I have an A5 without the buzzfix and
> so far I haven't had any buzzfix related issues. Just some minor tweaks
> to the mic volume have sorted out the noise issues on SHR for me.
>> > > The FreeRunner was my first smart phone, and I've gotten used to
>> > > it.  I don't want to tether myself to either Apple or Google, and
>> > > I definitely don't want a Microsoft smart phone, so that leaves
>> > > the FR, or some other smart phone that I haven't found yet.
> There's always the Nokia N900 which is really pricey but a very nice toy
> indeed. I'm a cheapskate but the friends I know that own the N900 are
> pretty happy with it so far. 
> Good luck Laura ;-)
> Brian

My FR has been sitting all day turned off, and I just went upstairs to prep
it for an overnight without the battery, but I decided to see if I could get
to the NOR boot menu one more time before I let it sit overnight, and
whadayaknow... it came up to the boot menu.  :D

The USB port still isn't recognized, so I can't charge it yet, but I can at
least reflash now.  :)

Thanks Brian!

View this message in context:
Sent from the Openmoko Community mailing list archive at

More information about the community mailing list