Serious problems after failed upgrade

vancel35 vancel at
Thu Mar 18 17:43:10 CET 2010

Brian-32 wrote:
>> > On Wed, 2010-03-17 at 08:28 -0800, vancel35 wrote:
>> > > Unfortunately I cannot get into the boot menu, and my desktop
>> > > computers don't see the FR.  Not only that, but last night I tried
>> > > the 1 amp wall charger to see if the higher output would get it to
>> > > recognize the USB/power cable, and it didn't.
>> > > 
> This is probably a stupid question but have you tried removing the
> battery and leaving the FR unplugged for ~15 minutes and then see if
> you can get the NOR boot menu? I only ask because I've had a similar
> issue and this solved my problem.
Further update this morning, since letting the FR "rest" worked, I
re-flashed the kernel with the SHR kernel from March 4th (I think it's the
4th... it's the most recent kernel flash image on the site).  To see if the
kernel modules were what were preventing the USB from being recognized, and
the USB is still unrecognized.  My last backup was done a week or two ago. 
I think I've only added a couple of appointments since then (gpe-calendar).

Brian-32 wrote:
> As far as the desktops not seeing the device via USB do you get any
> useful info from doing an lsusb or lsusb -vv as superuser ? What does
> ifconfig say ? I recommend trying this on both the FR and your
> desktop. Perhaps the device name is different from what it normally is.
> I use the following on my desktop to get networking up:
> ip addr add dev eth4;iptables -A POSTROUTING -t nat -j
> MASQUERADE -s;sysctl -w net.ipv4.ip_forward=1
> Your device may vary in the above example the FR is eth4. 
>> > > The interesting thing about the USB port is that if I plug the
>> > > adapter into the FR while it's turned off, it recognizes the
>> > > connection and boots (as expected) but somewhere along the way the
>> > > USB port is completely disabled. I don't know if it's a mokonnect
>> > > failure or what, but something is completely hosed.  So much that
>> > > I used to be able to take the battery out as long as it was
>> > > connected to the charger, but now it turns off as if it wasn't.
>> > > 
> It sounds like the USB port is okay but since Qi doesn't initialize
> USB you have to rely on the kernel to do it and it sounds like your
> install isn't.
The DFU works now, but once it's booted, it's as if a disconnected cable is
plugged into my desktop.

Brian-32 wrote:
>> > > I also need the buzz fix done on my phone, so if there were a US
>> > > company that I could send the phone to that would do that work,
>> > > maybe they could reinstall the bootloader so that I could at least
>> > > get to the boot menu. That's really all I need is to get to the
>> > > boot menu and I can do the rest from there.
>> > > 
> I hope you get the issue resolved I have an A5 without the buzzfix and
> so far I haven't had any buzzfix related issues. Just some minor tweaks
> to the mic volume have sorted out the noise issues on SHR for me.
> Good luck Laura ;-)
> Brian
My buzz may be software related too, because I first started getting
complaints about buzz after I upgraded in February.  I had never had any
complaints before that, so I may just be able to alter a configuration and
get it fixed.  I have the skills to do the buzz fix on my own (experience
with circuit board soldering and modification), but I'm not sure my current
soldering gun has a fine enough point (Cold Heat).  I was considering doing
mine anyway and then offering up a buzz-fix party or maybe do it for those
that can't.  I was hoping to be able to take the lazy way out.  ;)


View this message in context:
Sent from the Openmoko Community mailing list archive at

More information about the community mailing list