[QTMoko] Getting online

nlis7 at bitte-wenden.de nlis7 at bitte-wenden.de
Fri Mar 26 10:03:16 CET 2010

Hello dear folks,

I'm struggling with getting online running v19.

In the past (and on othre distros) safest way seemed to be net-via-usb.

Following the instructions at 
http://wiki.openmoko.org/wiki/USB_Networking#For_devices_showing_as_usb0 I set 
up on a Debian Sid host which identifies the device as usb0:

# /etc/udev/rules.d/80-freerunner.rules

KERNEL=="usb[0-9]*", DRIVERS=="cdc_ether", ACTION=="add",  
RUN+="/usr/local/sbin/freerunner-usbusb-add.sh %k"


# /usr/local/sbin/freerunner-usbusb-add.sh

busNum=$( printf %.2d $( expr match "$1" "usb\([0-9]*\)") )
ip link set "$1" address de:8b:f4:79:0b:$busNum &> /dev/null
iptables -A POSTROUTING -t nat -j MASQUERADE -s
echo 1 > /proc/sys/net/ipv4/ip_forward
) &
exit 0


On executing freerunner-usbusb-add.sh I get the following error msg:

Cannot find device "de:8b:f4:79:0b:00"

The accurate bus-id extracted from /var/log/messages is de:8b:f4:79:0b:b1
I also tried replacing the 2d in the third line of freerunner-usbusb-add.sh 
with b1, leaving the whole $busNum variable out and supplying the complete 
bus-id with $busNum attached, but always end up with the above error message.
Any ideas? Sadly I don't really know what this script does exactly. 

Second attempt: WiFi

When trying to ifup eth0 I get a bunch of the following errors:

ioctl[SIOCSIWENCODEEXT]: Operation not supported

udhcpc sends a few discoveries but exits with "lease failed".

When reproducing this for this message it worked out of the sudden and I got 
an IP and a gateway address. I couldn't ping anything out there, ifdowned and 
ifup again and am back to the prior problem again.

I hope someone can make sense of any of the above, being able to get online 
for some additional packages, eg mplayer would be highly appreaciated and 
making this wonderful distribution amazing. (:

Thanks a lot,

More information about the community mailing list