[QtMoko] no WLAN support nor USB networking with Windows 7 in QtMoko v18? (FR unusability rant)

Brolin Empey brolin at brolin.be
Mon Mar 29 01:44:04 CEST 2010

Hello fans of cute trolls ;),

I finally used tar to back up my QtMoko v14 installation in my FR’s 
onboard NAND, then reflashed QtMoko v18 because, among other annoyances, 
I was tired of missing incoming SMS messages until I restarted QtEI. 
Anyway, QtMoko v18 boots and appears to work, but the WLAN interface 
does not exist and USB networking with Windows 7 does not work at all, 
even though it partially worked (was intermittent) with QtMoko v14.  No 
Neo Connection is created when I connect my FR to my Windows 7 laptop, 
so I cannot bridge Neo Connection to Local Area Connection so I cannot 
ssh from Cygwin on Windows 7 to QtMoko v18.  The WLAN interface somehow 
appeared after I started writing this message, but it is useless 
because, of course, I cannot connect to my WLAN at home.  I tried with 
both the QtEI GUI and the CLI.  I decided to finally try using Bluetooth 
to network QtMoko v18 with Windows 7, but QtEI says Bluetooth is 
unavailable when I open Bluetooth from the Main Menu.  I tried using 
“Power on Bluetooth” in the Dev Tools, but, of course, it does not 
appear to do anything so I cannot even configure Bluetooth on QtMoko 
v18, so there is no point in continuing trying to configure Bluetooth. 
I do not want to have to reboot my FR just to get Bluetooth working 
again in QtMoko v18 because Bluetooth will probably die again after I 
suspend and resume.  So, since the FR’s WLAN is useless, as usual, 
Bluetooth is broken, and USB networking with Windows 7 is completely 
broken, I have to (try to) use my wired Ethernet LAN again, even though 
I think this is how my FR’s USB connector got broken last time.  Of 
course, though, I cannot even enable logical USB host mode on QtMoko v18 
(at least electrical USB device mode works, which is surprising because 
it means something actually works on my FR! (fail)) because the Dev Tool 
to enable USB host mode appears to do nothing, which makes sense if it 
uses sysfs because there is no usb_mode file in sysfs.  lsmod does not 
list ohci-hcd, so I guess either the module is not loaded or it is built 
into the kernel image.  I cannot load ohci-hcd because it does not exist 
in /lib/modules/, which appears to be missing many modules.  Why? (fail) 
  Are most modules built into the kernel, or were these modules not 
built at all because they would be too useful?  I need to restore at 
least my QtEI config and user data from my QtMoko v14 backup tarball, 
but this is a huge PITA without ssh access to QtMoko v18 because I have 
to use the tedious onscreen keyboard in qterminal.  QtMoko v18 has no 
Internet access because I cannot connect it to my PC, nor my home 
(wired) LAN nor WLAN, so I cannot install mc to see if the version in 
lenny has been upgraded so it is no longer useless because of the 
regression which prevented me from listing the contents of my QtMoko v11 
backup tarball on QtMoko v14, so I have to use tar from the command 
line, which takes ages to do anything, such as listing archive contents 
and extracting specific files.  I probably use QtMoko as a PDA more than 
a phone:  I rely on it for my personal calendar and had over 400 tasks, 
including completed tasks.  I do not know how anyone considers paper 
calendars on their wall at home useful because they do not have them 
with them when they are away from home;  I am often away from home when 
I make appointments.  Anyway, I know I have appointments next week (the 
week starts on Monday, not Sunday, for me.  I hate calendars which start 
on Sunday.), but I cannot access my calendar because I cannot restore my 
QtMoko v14 backup.  I also have at least 2 upcoming events I need to add 
to my calendar, but I cannot do so, so I have to rely on people to call 
me to remind me because I will probably forget if I do not have the 
events in my calendar.  I know I should have properly backed up my 
QtMoko v14 installation by saving a disk (memory) image of the onboard 
NAND instead of creating a tarball of the files, but I was very 
foolishly optimistic QtMoko v18 would work better (be less unusable) 
than v14. (epic fail)  I know this message has a very negative tone, but 
I am currently very frustrated because my FR is still unusable after 
spending most of my weekend so far trying to upgrade from QtMoko v14 to 
v18.  Alishams Hassam (in To above) asked me how it could take so many 
hours for me to upgrade QtMoko;  now he has a written record of the 
explanation.  As much as I want to make my FR usable, everything always 
seems to end up being a huge PITA.  I think I should really buy an N900 
because I want a usable Linux phone (proper, standard, Debian-based 
Linux, not crappy, non-standard Android Linux) which does not literally 
take days to upgrade to fix problems which should not have been present 
in a release in the first place. :((


Sometimes I forget how to do small talk: <http://xkcd.com/222/>

“If you have to ask why, you’re not a member of the intended audience.” 
— Bob Zimbinski, <http://webpages.mr.net/bobz/ttyquake/>

More information about the community mailing list