Kernel panic on Freerunner QtMoko boot

Harry Prevor habstinat at
Sat Nov 17 04:19:24 CET 2012

About a week ago I installed QtMoko on my Freerunner as it's first
distribution and all was well. However, for reasons mostly unrelated
to this post the install broke so I decided to reinstall QtMoko using
instructions from here:

However, to my surprise I wasn't able to get anything to work. Here's
what I've tried so far to no avail:

--Flashed the Qi bootloader several times;
--Flashed the kernel several times to NAND;
--Flashed both the .ubi and the .tar.gz rootfs to NAND (as different
attempts and not at the same time, of course)
--Done all of the above with both df-util and the GUI neotool;
--Made an ext3 partition on my 8GB microSD card that was working with
QtMoko previously and unzipped the .tar.gz rootfs onto it;
--Checked the md5sums of all downloaded files.

Every time, I get a kernel panic on boot. I'm not particularly good at
interpreting kernel error messages, so I'll let the last few lines of
the ouput with the debug kernel parameter added speak for itself:


What can be done to fix or debug this further? Just to note, I'm not
100% sure whether Qi has been installed correctly (although it must
have been before if I was able to flash QtMoko onto it a week ago) as
when I boot while holding AUX I still get a menu bearing the U-Boot
text at the top, but it seems like Qi is working because when I hold
the power button I get extra kernel debug information which seems to
be a feature of only Qi (?).

Thanks ahead of time for responses.

Harry Prevor

More information about the community mailing list