Kernel panic on Freerunner QtMoko boot

Radek Polak psonek2 at
Wed Nov 21 08:03:32 CET 2012

On Wednesday, November 21, 2012 04:17:19 AM Harry Prevor wrote:

> Oddly enough, I am still getting this same UBIFS kernel panic even
> when I successfully flash a JFFS2 image I made of QtMoko onto the
> Freerunner. I made the image by unzipping the .tar.gz rootfs from
> SourceForge into a folder and then running "mkfs.jffs2 -r
> qtmoko-rootfs/ -p -e 0x20000 -o qtmoko-debian-gta02-v48.jffs2" on the
> folder. I then ran "dfu-util -a rootfs -R -D
> qtmoko-debian-gta02-v48.jffs2" and it seemed to have flashed
> successfully, but I still get that darn error on every boot. I've also
> tried unzipping the .tar.gz into my ext3 uSD card, but it didn't seem
> to do anything either. Is there any reason that this should be
> happening? Are there any officially released non-UBIFS rootfses that I
> can use for the Freerunner? What specifically would y'alls reccommend
> to debug / fix this?

There is still good old v26 release:

If you want to create jffs2 out of tarbal you also need to change /etc/fstab 
and most likely "root" and "rootfstype" arguments in bootloader. But maybe you 
could boot it with NOR uboot.



More information about the community mailing list