Kernel panic on Freerunner QtMoko boot

Harry Prevor habstinat at
Fri Nov 23 15:33:42 CET 2012

On 11/21/12, Ivan Matveev <imatveev13 at> wrote:
> I had a similar problem. Somehow it went away.
> See

Hm. Oddly enough, I tried exactly that (flashing the kernel to u-boot,
then reflashing qi, the kernel, and the rootfs all to their correct
places), and I'm still getting the same panic. Right now I've got
Hackable1 running because it was jffs2, but I'd really like to run
QtMoko on my Freerunner. I was able to flash the QtMoko ubifs image a
few weeks ago and it worked, so it's odd how nothing seems to be
working now.

Out of curiosity, why was the switch to ubifs made? Can jffs2 images
of QtMoko still be produced? I'm kind of hesitant to try the v26
release because I'd like to have the latest version for my Freerunner.
What exact changes would I have to make to my tarball, and how would I
go about changing bootloader arguments?

I'm not sure if I have Qi installed correctly, which may also be the
issue; I flashed it successfully to u-boot, but when I boot while
holding AUX to get to DFU mode where I do my flashing I still see
"U-Boot 1.3.2-moko12" at the top and "*** BOOT MENU (NOR) ***" as a
header. Should I be seeing Qi instead?

Any ideas about the above issues?

Harry Prevor

More information about the community mailing list