setting up gprs properly

Ed Kapitein ed at
Fri Nov 30 11:19:47 CET 2012

Hi Robin,

If you run pppd with the "nodetach" and "debug" parameters manually, you
will get quiet a bit of information about which authentication protocols
are tried.
You need to set up a connection file in (default in /etc/ppp/peers) 
with the details about the connection.
And a  chat script to handle setting up the connection ( eq
/etc/ppp/gprs-connect-chat )

Good luck with your trouble shooting!

Kind regards,

On 11/30/2012 07:34 AM, robin wrote:
> I am trying to set up my gprs in both shr and qtmoko. unfortunately I do 
> not get a data connection with neither of them.
> I am using and according to their website there are either 
> APN:
> Username: blau
> Passwort: blau
> Authentifizierungstyp: PAP
> so I wonder if the authentication might be a problem, as I have not found
> a place to set it specifically. 
> then they have a specific access if you want to do tethering (I haven't quite
> understood how this is different to the first one:
> APN/ Zugangspunkt:
> ------------------------------------------------------
> Datenträger <- Datadrive: Paketdaten <- Packagedata
> ------------------------------------------------------
> IP-Adresse: dynamisch
> ------------------------------------------------------
> Benutzername: eplus
> ------------------------------------------------------
> Passwort: gprs
> but still no success. 
> If I set it up with qtmoko I get the little G icon on the homescreen. If I then
> click on "start" the icon becomes a filled G for a microsecond, before going
> back to the unfilled/unconnected state. Any hints, also how I can investigate 
> this?
> br
> robin
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list