QtMoko on my GTA02 - first impressions and questions

Tiago Bortoletto Vaz tiago at debian.org
Sun Jul 21 19:15:27 CEST 2013


On Mon, Jul 01, 2013 at 04:42:23PM +0200, Radek Polak wrote:
> On Monday, July 01, 2013 11:23:36 AM Nick wrote:
> > Hi there,
> > 
> > Yesterday I dug out my GTA02 from the shoebox it had been living in
> > for the past year and a half and put QtMoko on it for the first time
> > (it had always had SHR on it before that, but it proved too
> > unreliable as a phone).
> > 
> > My first impressions are that it is beautiful and seems to work much
> > much better than SHR. I am very pleased to find that :)
> > 
> > One major issue I had is that I put it to sleep by pressing the
> > power button, then about 30 minutes later decided to call it using a
> > different phone (to see what the ringtone was like, and how long it
> > would take to wake up), and was sad to find that it did not wake up
> > at all, even after pressing the power button. I had to pull the
> > battery out and start it again. Is this a known bug? Should I report
> > it? Is there somewhere I might be able to pull logs, or any other
> > thing I can do to help track down the issue?
> Hi,
> nice to hear that you like it. I am also wondering what to do with kernel 
> bugs. I dont have kernel skills to fix them and not many other people have 
> them too it seems. Only thing i could do is to use old 2.6.29 openmoko kernel 
> which was really stable IIRC.
> > The other problem I have found so far is that it won't connect to
> > the WPA-PSK-TKIP in my house for some reason. And when it was set to
> > automatically reconnect the whole phone slowed to a crawl until I
> > disabled that, I suppose as it continuously tried and failed to
> > connect. Any suggestions on things to try to get the wifi to
> > connect? And should I report the slowdown if it is set to
> > autoreconnect on the issue tracker?
> There are issues with wpa_supplicant on GTA02 in debian wheezy. You can check 
> https://github.com/radekp/qtmoko/blob/master/doc/txt/debian_rootfs_howto.txt
> and search wpa_supplicant for details. Maybe it's your case.

It's the case here. I've tried wpa_supplicant 0.7.3-6 but it seems very unstable
with the current qtmoko kernel version. And the default wpa_supplicant version
is just broken. In short, we can't connect to wpa networks with qtmoko v55 :(

Is there any chance to have the little patch applied to current wpasupplicant
version in qtmoko? (http://patchwork.ozlabs.org/patch/167925/)


  .''`.  Tiago Vaz                                    GPG  :      1024D/A504FECA
 : :' :  http://acaia.ca/~tiago                       XMPP : tiago at jabber.org
 `. `'   tiago at debian.org                          IRC  :       tiago at OFTC
   `-    Debian GNU/Linux - The Universal OS               http://www.debian.org

More information about the community mailing list