Resume bug on 2.6.39 kernel identified! (was QTMoko v55 GTA02 flash issue)

Peter Viskup at
Thu Jan 30 07:28:37 CET 2014

Radek Polak:
> On Monday, January 20, 2014 05:04:53 PM Jake Drexel wrote:
>> the mmc0 device is actually where the ar6000 (wifi) is conneted. I had
>> the same problem with the 2.6.39 kernel on shr. The issue looks hw and
>> sw related. My wifi-board was not connected very well but with older
>> kernel it still worked, which is strange.
>>  Here is the ticket where I tried to document the issue i saw:
> Hi,
> it seems that thanks to your mail we have discovered resume problems on 2.6.39 
> kernels!
> I tried rmmod ar6000 and i cant reproduce my resume issues anymore! I had 
> running my dial script over night. Freerunner now shows 333 succesful resumes, 
> while it used to fail after 30 resumes before.
> So please if you are using 2.6.39 kernel edit /etc/modules, remove or comment 
> out line with ar6000, reboot and report if your resume issues are gone.
> Regards
> Radek
> _______________________________________________
> Openmoko community mailing list
> community at

Confirm the removal of that module make the responses of QtMoko for
suspend much quicker on my phone.
Within my investigation I recognized the qpe process was hanging in
disk-sleep state.
If that module is included in newer version of Linux kernel it would be
probably helpful to look for the changes made.

Do we miss only WiFi functionality once the module is removed?

More information about the community mailing list