cankiri on freeruner

Jozef Mlich xmlich02 at
Tue Aug 19 13:59:32 CEST 2008


i would like to run cankiri (application which can create screencast) on
FR, but i am not able to do this.

First of all i have removed systray calls from cankiri and added a few
lines to __main__, so expected approach now is a starting application
form terminal, selecting a destination file and application termination
with ctrl-c. This modification is at

Second i had installed following packages:
and some more python and gstreamer packages (not sure which exactly).

And finally i tried to run cankiri, but there is some problem with
theora, which i can't resolve:

root at om-gta02:~/cankiri-0.1# python ./ 
oggmux name=mux ! filesink name=sink ximagesrc show-pointer=true
name=video ! ffmpegcolorspace ! videobox top=0 right=0 bottom=0 left=0 !
video/x-raw-yuv,width=1280,framerate=10/1,height=1024 ! theoraenc
quality=32 ! mux.
Traceback (most recent call last):
  File "./", line 397, in <module>
  File "./", line 366, in start_recording
    self.pipeline = gst.parse_launch(pipeline)
gobject.GError: no element "theoraenc"

So i tried to create package from
My package is at:
But i am not sure if its made correctly, because there was some problem
with m4 scripts in configure. I don't understand to this at all, so i
tried to use google and add "m4_pattern_allow(AS_AC_EXPAND)" and lately
comment some lines in 

So can anyone help me with this? 

  with best regards,
  Jozef Mlich <xmlich02 at>

More information about the devel mailing list