Openmoko Bug #1846: hidd missing from "testing" feed

Openmoko Public Trac bugs at
Tue Aug 26 17:16:25 CEST 2008

#1846: hidd missing from "testing" feed
    Reporter:  Mercury  |        Owner:  openmoko-devel
        Type:  defect   |       Status:  new           
    Priority:  normal   |    Milestone:                
   Component:  unknown  |      Version:                
    Severity:  normal   |   Resolution:                
    Keywords:           |    Blockedby:                
Reproducible:           |     Blocking:                

Comment(by Mercury):

 Thanks :)  That helped a lot.  Here's how I got it working:

 I followed the instructions here to bond the device (otherwise referred to
 as 'pairing'),  And after
 bonding was complete, while the light was still blinking, I followed the
 instructions here, to
 register the keyboard as an input device.

 Then I got the error
 'input[1555]: Authorization denied: Authorization agent does not exist'
 When I tried to use the keyboard (apparantly once it's bonded and
 registered as a keyboard, the keyboard will attempt to automatically
 connect to the device it's bonded to whenever you hit a key)

 I fixed it with this command:
 dbus-send --system --type=method_call --print-reply --dest=org.bluez
 /org/bluez/hci0 org.bluez.Adapter.SetTrusted string:AA:BB:CC:DD:EE:FF

 And now it works ^.^  Mostly :(  I have a new problem.

 When I press some keys, it works, when I press other keys, it doesn't.  I
 don't think it's related to the new way of bluez keyboard input though,
 because I grabbed an old copy of hidd and tried that and it had identical
 behaviour.  This is very reminiscent of the problem where some keys would
 work and others would not when you would try to enter a phone number.  Has
 that problem been identified?

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list