Unable to modify U-boot splash

ramsarvan pl_ram2003 at yahoo.com
Fri Dec 26 17:52:11 CET 2008

Hi All,

I tried modifying the uboot splash and did the following steps:
1) Downloaded the perl script from
2) chmod a+rx *.pl 
3) Installed the netpbm
4) Taken the image file (older splash screen) from
   and named it System_boot.png 
5) Ran: ./imghs.pl | gzip -9 > splash.gz 
6) In NOR flash mode, did, sudo ../bin/dfu-util -a splash -R -D splash.gz 
7) ls -l gives the filesize as 2456 which is 0x0998 (< 0x5000)
-rw-r--r-- 1 ram ram  2456 2008-12-26 23:57 splash.gz
8) Since the filesize is not exactly 0x5000, I sent the following commands
in NOR flash mode,
setenv splashimage nand read.e 0x32000000 splash 0x1000\; unzip 0x32000000
0x33d00000 0x96000
9) Booted the device, But the splash screen is not coming and some kind of
distorted image
is shown.

Can anyone please tell me what am i doing wrong?
Anybody tried this and got success?

View this message in context: http://n2.nabble.com/Unable-to-modify-U-boot-splash-tp1914345p1914345.html
Sent from the Openmoko Devel mailing list archive at Nabble.com.

More information about the devel mailing list