Unable to modify U-boot splash

ramsarvan pl_ram2003 at yahoo.com
Sat Dec 27 05:45:39 CET 2008

Thank you much Werner.

It works :)
Sorry for not mentioning properly. I have GTA02.
I was trying out the command in NOR Boot mode & didn't work.
Then I tried the command in NAND Boot mode and it worked.


Werner Almesberger wrote:
> ramsarvan wrote:
>> Used the perl script you mentioned and I am now getting the same 17216 
>> bytes after compression.
> Much better ! ;-)
>> But still I am not getting the splash image and I m seeing the words
>> poweroff at the top left corner.
> Seems that you're still using the GTA01 framebuffer address, but since
> you mention NOR, you appear to have a GTA02. The command should thus
> be
> setenv splashimage nand read.e 0x32000000 splash 0x4340\;
>   unzip 0x32000000 0x8800000 0x96000
> Also, you don't have to boot from NOR. In many ways, this will only
> complicate things if all you want is to change the environment,
> because the NOR provides its own environment.
> The "poweroff" means that u-boot decided to power off, e.g., because
> you released POWER early.
> - Werner
> _______________________________________________
> devel mailing list
> devel at lists.openmoko.org
> https://lists.openmoko.org/mailman/listinfo/devel

View this message in context: http://n2.nabble.com/Unable-to-modify-U-boot-splash-tp1914477p1979424.html
Sent from the Openmoko Devel mailing list archive at Nabble.com.

More information about the devel mailing list