Anyone using Ubuntu 8.04 Hardy Heron with Mokomakefile or OE

Jim Morris ml at
Mon Jul 21 21:30:22 CEST 2008


Before I go and spend another 4 hours on this, is anyone successfully using the latest Ubuntu to 
build via Mokomakefile or OE?

I have spent several hours both on OE and Mokomakefile.

The problems I seem to run into are show stoppers, ie the tools won't build.

I can't believe others haven't run into these problems, but maybe no one is using 8.04.

Several of the initial problems I ran into with OE I was able to find emails or bug reports on and 
had to apply my own patches, as they have not been fixed upstream (most were reported by others). I 
finally ran into one trying to build which I simply couldn't figure out how to 
fix, so gave up on that route.

Then I tried Mokomakefile and this seems to get much further but I also get an error where it 
reports an error about native AS not supporting the -Qy flag, again not an easy thing to fix.

So in both cases it never gets through building the tool chain.

If someone has actually got this stuff to work on 8.04 with no problems, then there must be 
something in my environment, or maybe they solved all these problems and if so can I get the recipe?

Thanks for any help here.


Jim Morris,

More information about the devel mailing list