Problem with USB camera drivers

Walter Christie wheeltracks1932 at
Wed Apr 22 12:04:00 CEST 2009

I set up modules for the linux v4l and uvc drivers. These make properly
without errors. I also see the USB devices with the lsusb command. I'm
following this procedure:

When I set the FreeRunner as a host, and plug in the camera into it, I get the following message:
v4l1_compat: version magic '2.6.2420081103.git7172ec57
 preempt mod_unload ARMv4 ' should be '2.6.24-20081103.git7172ec57 preempt mod_unload ARMv4 '
Evidently, the dash after the "2.6.24" is absent when I make... 

make/make install is a two-stage process. First I do a make
menuconfigure on the kernel source itself, in a directory where there
is a dash in the name. I go into General Setup -> Local version, and
enter in the version starting from the dash. Then, I save the
configuration of the menuconfig, and run a make/make install on the
M-sound modules.

When that ends, I go into the source for the
UVC drivers, do a make menuconfig (which has a lot less resulting
options then the previous menuconfig), select the drivers I want, and
do make/make install.

I have tried doing this - 
make EXTRAVERSION=-20081103.git7172ec57

doesn't seem to do anything different. I tried to put extraversionin
the Makefile. Still no difference - get that error message when
attaching the camera, so it seems like the module isn't being loaded.
Is there an easy solution to this, or will I have to abandon the effort of making a USB camera work?

--- On Wed, 4/22/09, Joerg Reisenweber <joerg at> wrote:
From: Joerg Reisenweber <joerg at>
Subject: Re: Problem with USB camera drivers
To: devel at, wheeltracks1932 at
Date: Wednesday, April 22, 2009, 2:02 AM

Am Mi  22. April 2009 schrieb Walter Christie:
> Hi all,
> Trying to get uvc cameras working with the freerunner... get this error
plugging in a quickcam 5000:

> usb 1-2.1: configuration #1 chosen from 1 choice
> input: DELL DELL USB Keyboard 
as /devices/platform/s3c2410-ohci/usb1/1-2/1-2.1/1-2.1:1.0/input/input7
> input: USB HID v1.10 Keyboard [DELL DELL USB Keyboard] on usb-s3c24xx-2.1

seems there's the wrong driver loaded for this MAnufacturer/device ID
Keyboard doesn't sound like quickcam


-------------- next part --------------
An HTML attachment was scrubbed...

More information about the devel mailing list