glibc_2.6.1 build fails

neomilium neomilium neomilium at
Tue May 26 17:15:46 CEST 2009


2009/5/24 Aapo Rantalainen <aapo.rantalainen at>:
> wget
> make setup
> make fso-gta02-testing-image
> It compiles 3hours and then stucked on error:
> [...]
I had the same error using Debian Lenny (x86). You can try to disable
glibc locales.

> Should I make fso-gta02-unstable-image instead of testing? What else I can try?
Due to lack of support and users/developers of "FSO only" image, I
switch to SHR which is FSO image + apps and have a better build
documentation :
But don't enjoy too fast, I had have some problems during image
building : GlibC locales should be disabled and this bug can appear
(and not yet fixed in repo) :
If you have problems too, you should consider using IRC (on
#openmoko): many nice guys can help you.

I had tried many build systems to develop on FreeRunner (FSO image
builder, SHR image builder, Hackable:1, Debian for FR (which doesn't
really provide image) and OpenWrt) and I was really surprise to see
that the better build system for FreeRunner (IMHO) is OpenWrt ! It
make things very easy for developers but produced image (with full
suite : FSO, e17, paroli, etc.) is not customized for users as SHR can
be. So I switch between OpenWrt and SHR.. waiting for more
user-oriented OpenWrt image.
Another good point for OpenWrt : you can choose your libc
implementation glibc, eglibc or uClibc(default) and uClibc goes faster
than glibc..

More information about the devel mailing list