GSM firmware flash bricked GTA02 GSM modem

W. B. Kranendonk wankelwankel at
Mon Sep 21 23:30:42 CEST 2009

I flashed my Calypso using the image from

All went seemingly OK, as after a while the friendly green "DONE" showed up.

Since then however, I (nor my freerunner) have not been able to access the SIM anymore.

I tried repeating the flashing procedure, with the same result. Now I paid attention to the blue output as well, which showed I was trying to flash an identical firmware (,
 "In some case you may receive this: 
  (fluid, version 3) ok
  Checksumming (269 * 8kB = 2152kB):  ok
  Flash Detect: (0xEC, 0x22A0) Samsung K5A3240CT ok
  Program: (0 sectors, 0*8k=0k) () ok 
My output's a bit different though: it says fluid, version 2.27.

I am a bit hesitant now to continue and follow the instructions for a manual firmware download, since this fluid business is so picky on the syntax.

Any advice on how to continue from here?

Best regards,



More information about the devel mailing list