Error while compiling 'trousers'

Amruta Gokhale amrutag at
Fri Feb 19 16:10:17 CET 2010


I am trying to build the 'trousers' library 
( on Ubuntu 9.04 for openmoko.

Since I could not find trousers after doing 'opkg list | grep trousers', 
I assume it's not
yet available in pre-compiled toolchain.

I followed the instructions at :

I am getting the following error after doing 'make' :
/bin/grep: /usr/lib/ No such file or directory
/bin/sed: can't read /usr/lib/ No such file or directory
libtool: link: `/usr/lib/' is not a valid libtool archive
make[2]: *** [] Error 1
make[2]: Leaving directory 
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/src/trousers/openmoko-trousers-0.3.1/src'
make: *** [all-recursive] Error 1
$:~/src/trousers/openmoko-trousers-0.3.1$ locate

I believe the libtool is looking for the 'libpixman' library in the 
wrong place - /usr/lib instead of
What do I need to do to fix this?

There is a similar problem reported in another thread :

And I tried that solution -- setting the LIBTOOL_SYSROOT_PATH. But 
'make' gives the same error.

I have attached my environment settings.

I will appreciate any help.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: env.txt

More information about the devel mailing list