Bad SD card controller?

ttz ttzweb at
Sat Oct 20 12:04:48 CEST 2007

Since I got my P1 a week ago, I had had trouble to get the SD card mounted.
I tried with the following builds: 




also with my own builds and couple older ones. All kernel boots were
fine but none of them gave me the device /dev/mmcblk0p1, thus
I never got the SD card mounted.  

The dmesg shows there are I/O errors:

root at fic-gta01:~$ dmesg | grep mmc
<7>mmc_set_power(power_mode=0, vdd=0
<7>mmc_set_power(power_mode=2, vdd=20
<6>mmcblk0: mmc0:e624 SU512 495488KiB
<6> mmcblk0:<3>mmcblk0: error 1 transferring data
<4>end_request: I/O error, dev mmcblk0, sector 0
<3>Buffer I/O error on device mmcblk0, logical block 0
<3>mmcblk0: error 1 transferring data
<4>end_request: I/O error, dev mmcblk0, sector 0
root at fic-gta01:~$ 

I tried to force a mount,

root at fic-gta01:~$ mount /dev/mmcblk0 /media/card
/dev/mmcblk0: Input/output error
mount: /dev/mmcblk0: can't read superblock
root at fic-gta01:~$ 

I tried both MMC cards coming with my advance set as well as 
one of my own.  Two cards I formated on my linux box with no 
problem to read and write otherwise.  One (original) card I didn't 
do any format with it.  But nothing mattered whence they were put
on my P1 unit.   I used both VFAT and ext2 formats.

I tried to looked into the card from the console:

GTA01Bv4 # mmcinit
trying to detect SD Card...
Manufacturer:       0x03, OEM "SD"
Product name:       "SU512", revision 8.0
Serial number:      281088817
Manufacturing date: 8/2007
CRC:                0x21, b0 = 1
size = 2329935872
mmc_block_read: err SDIDSTA=0x00000024
GTA01Bv4 #

GTA01Bv4 # ext2ls mmc 0
mmc_block_read: err SDIDSTA=0x00000024
bad MBR sector signature 0xfd33
** Bad partition - mmc 0:1 **
GTA01Bv4 #

So it looks like there is block read error. I don't think my cards
are bad, so I kind of suspect that I may have a bad disk controller. 

Any idea on this?  Who should I talk to at FIC about the possible
hw defect?



More information about the device-owners mailing list