Booting from SD Card using FreeRunner (as shipped)?

Simon Moore simon at
Fri Jul 4 08:30:36 CEST 2008


As an experiment, I was trying to see if I can get a FreeRunner (as 
shipped) to boot new images from the SD Card i.e. without having to 
resort to dfu-util, as not everyone has Linux PCs ready to run dfu-util.

Currently, I'm having no success, and I'm beginning to wonder if I'm 
just very stupid, or if the uBoot as shipped on the FreeRunner is a 
little suspect?

I've tried using instructions (and variations thereof) from here:

I'm generally running into two problems:

1. Nothing I've tried allows it to successfully mount the rootfs e.g. 
from /dev/mmcblk0p2 (using FAT+ext2 partitions on the SD Card)

2. 'savenv' appears to fail - it does an Erase, then drops back to the 
uBoot prompt; I've only ever had it once do an Erase...Write cycle

If you have got this to work, could you share details on your 
partitioning and uBoot environment variables etc.

Simon Moore
User:SNMoore on the wiki

More information about the device-owners mailing list