FR and ASU - how to start GTK apps?

Daniel Mewes danielmewes at
Sat Jul 12 14:23:30 CEST 2008

On Sat, 2008-07-12 at 13:47 +0200, Torfinn Ingolfsen wrote:
> I tried changing the icon line in the .desktop file for
> openmoko-agpsui so that it used an existing icon, but that didn't
> work. Not even after a reboot.

The following procedure worked for me:
Store the icon as a PNG file into /usr/share/pixmaps (I was not
successful with an xpm file for example). Then change the Icon line of
the desktop file into the file name of the png, including the
suffix .png (some of the existing files omit the suffix, but this did
not work for me).

However it is weird, that you cannot see the entry although there is
a .desktop file. Even without any Icon line, the application should show
up in the launcher. Perhaps there is some other mistake in the desktop
file? Perhaps the Categories are not correct? Try changing those to
Office; or something like that. Or start over using one of the other
desktop files as a starting point.

Kind Regards.

Daniel Mewes (daniel at
Phone: 0800 DAMEWES (3263937; from inside Germany, I call back)
Mobile: +49 (0) 160 8577603
Pager: danielmewes at

More information about the device-owners mailing list