No audio

Andy Powell openmoko at
Sat Mar 15 16:46:40 CET 2008

On Saturday 15 March 2008 05:59, clare wrote:
> On Fri, 14 Mar 2008, Andy Powell wrote:
> > On Friday 14 March 2008 14:58, Kevin Dean wrote:
> >> The most stable snapshots are the 28 Feb 2008 images. No nightly image
> >> has had sound since then.
> <snip>
> > Have you tested my images?
> >
> >
> >
> > particularly the most recent image
> >
> > Andy
> Andy I did try it briefly, using an SD boot from that old file of yours
> u-boot-good-for-sd-boot-r13_0_2632_0.bin  It seems to have gone from
> your site. luckily I kept a copy.

Hmmmm it's still there...

but it is old....
> (I tried a FIC replacement which seemed to require an entirely different
> way of populating the SD card, and I failed with that.)
> With your latest rootfs:
>    it rang my motorola, connected but with a numbered error, the call was
>    inaccessible.
>    try in the other directions
>    it tried for a long time no result
> The use of an old u-boot may affect it, It did affect "underground"
> quite strangely, changed the phone but helped the GPS.

I can't remember if that uboot suffered from the nand not erasing prior to 
flashing problem. If you are experiencing issues with other builds that seem 
to be erratic then this *might* be the cause.

You're obviously comfortable with flashing but there is a note to this effect 
on the wiki

you just need to be sure to specify which bit of the nand you are erasing 
otherwise it gets ugly fast. 

> I gave up but I have a lot I want to say:
> I think those few who supplied their own builds were really helpful, and
> the FIC daily snapshots are like that dance - 1 step forward and 2 back.

My builds are based on the development branch of openembedded so are a bit 
more bleeding edge than the standard FIC builds which are based on 
the "stable" Openmoko branch. This means that sometimes my builds can be a 
little broken or they can work wonderfully, having all the latest fixes. It's 
a bit pick and mix - I can't help that really, it's bleeding edge.

> this is the one I like best:
> FIC/OpenMoko-openmoko-devel-image-glibc-ipk-P1-Snapshot-20080118-fic-gta01.
>rootfs.tar.gz I think it must be one of the last before they went berserk
> trying to mix GTA01 and GTA02? Not only does it have a perfectly good
> terminal and keyboard, with a keyboard icon in the top row, but it  makes
> calls in both directions which ring at the other end and carry conversation
> voices in both directions and hang up successfully.

I think the issues with my builds and audio are fixed from 13th on, since I 
noted that the state files and .bb files were updated in oe, so forced a 
rebuild. You can certainly tell if any image has the issue with its state 
files by doing something like

alsactl -f /etc/gsmhandset.state restore

If it generates 3 lines of error then you need the updated .state files which 
I've made available here:

they just need to be copied to /etc/



More information about the device-owners mailing list