[Hardware] sudden freeze of gta02

Werner Almesberger werner at openmoko.org
Mon Apr 28 15:45:28 CEST 2008

[ I hope you don't mind that I'm bringing this thread back to the
  hardware list, because the little trick I'm describing may be useful
  for others, and our team members from Germany may be able to help
  you. ]

M. Dietrich wrote:
> i tried but with no luck. gps has errors with debugboard connected
> (see #1372) and gsm seemed to have problems too.

Sounds like a mess :-(

> it's not possible to connect the debug board /after/ the crash right?

Hmm, you can do this, but it often has undesired side-effects.
(Such a shorting some signals, and then anything can happen.)

Might be a way to get into OpenOCD and halt the CPU, though ...
Yeah, just tried it. It works :-)

- bring up the system as usual
- let it die
- connect the debug board to the PC
- carefully insert the FPC on the Neo
- start OpenOCD on the PC
- telnet localhost 4444 and halt
- this should print something like
  target halted in ARM state due to debug request, current mode: Supervisor
  cpsr: 0x80000093 pc: 0xc0029f3c

Since your device has so many problems, if you live near any of the
other Openmoko developers in Germany (hmm, Raddestorf sounds a bit
remote), perhaps you could try to meet and try to run your code on
another device ?

- Werner

More information about the hardware mailing list