Bug #1024 (oscillating re-camping), a possible solution.

Werner Almesberger werner at openmoko.org
Wed Jun 10 15:32:59 CEST 2009

Nils Faerber wrote:
> For testing the process I tried to do the rework on a NEO1973 and
> promptly got into trouble - I was not able to remove the capacitor! Is
> it possible that it is glued to the board?

Oh, so I wasn't the only one with that luck. When I tried to
convince Dieter that replacing the capacitor was really easy,
I decided to give it a swift try on one of the GTA01
pre-production units I have and then brag about it.

My first try was the "single iron, lots of solder" attack.
To my great dismay, the cap didn't budge. I then went through
all my electronics torture chamber has to offer, hot tweezers,
etc., with pretty much the same lack of result. In the end, I
reduced the problem to a simple mechanical one that could be
solved with a dremel.

I didn't know the production models had glue as well. After
the accelerometer and (probably) the backup battery, that was
the only place where I've encountered glue so far. So it's
probably best to avoid trying to remove the cap, and just add
the new one in parallel.

- Werner

More information about the hardware mailing list